
How to use Google Earth and TransDEM to create routes for Trainz.

NOTE: It is assumed you have already followed the TransDEM Trainz Edition PDF 
instructions under section "Installing the TransDEM Ground Textures" (Page 14) and the 
instruction under section "Downloading and Installing the Trainz Mesh Importer" (Page 
16). Both procedures are necessary for creating routes. You may optionally install the 
"Wireframe Replacement Texture for Trainz Surveyor" by following the procedure on 
Page 16.

This tutorial will detail the procedures I used to create maps for T:ANE using Google 
Earth images. The process looks a bit complicated, and, I suppose it might be, but 
actually it isn't. Most of what you do right at first is repetitive but necessary to gather the 
images for your route.

1. Open Google Earth (known as GE from now on) and set it up for taking snapshots by:

    Going to the Tools menu and choose Options.

        On the 3D View tab

             Click Restore Defaults.
 Set Labels/Icon Size to Small
 Set Show Lat/Long to Decimal Degrees
 Set Units of Measurement to Meters, Kilometers

             Click OK

        On the View menu:

            Enable Toolbar
Enable Sidebar are enabled
Set Show Navigation to Automatically
Disable Overview Map
Enable Statusbar
Disable Atmosphere

        NOTE: If you wish to have the rail line highlighted by GE, you can expand the 
Layers at the left and move to Primary Database --> More --> Transportation and 
check the box for Rail. This will put a thin, black line on the GE image approximately 
where the rail lines run. It will also put a square blue marker for each station (which is 
handy for physically placing them later on your route).

2. Click the arrow to expand My Places:

    RIGHT-click on My Places, Choose Add and click New Folder

    In the pop-up that appears, change the default name to something meaningful for your 



purposes, like the name of your route. Ensure that "Allow the folder to be expanded" is 
checked. You can also enter text in the Description area if you desire. Click OK

3. Now you are ready to navigate to the area you are interested in. You can either drag the
globe around with the mouse pointer by holding down the left mouse button (LMB) to 
find your spot, or enter the name in the Search field above My Places. GE will rotate the 
globe and zoom in on the named place. You can use the mouse wheel to zoom in or out 
for height adjustment. The keypad Plus and Minus keys can also be used.

A bit of explanation about what you are about to do. 

In order for TransDEM (referred to as TD from now on) to convert all the images to 
usable UTM tiles, you should make sure that you encompass all of your chosen 
geographic area as well as a margin surrounding the area. If you make the margin large, 
say 2 or 3 kilometers away from the furthest points of your route, you can always trim the
baseboards created to make your route smaller. But, if you miscalculate and do not 
include enough of a border, it is hard to impossible to add them later with any accuracy.

In my case, the area surrounding the Kishigawa Line, which runs from Wakayama 
Station east to Kishi Station, I set up a square of images 18Km wide and 9Km deep. 
There is no reason you have to include images in the entire square, but if you don't, there 
will be large black areas on your final route in Trainz. I have also found that at extreme 
viewing distances from ground level in T:ANE that the GE images will look like real 
flora and habitation.

Each image (and I ended up with 110 images) is created using a GE feature called Add 
Placemark. This is an icon near the far left of the top toolbar and pictures a yellow 
pushpin. It is these pushpins that are used to create the images and make them usable to 
TD.

I recommend that you start at the northwest corner of your target area and work south and
to the east in vertical rows using the steps that follow.

Preliminary:

Open a Windows Explorer window and create a place on your hard drive to save all the 
images you will be generating.

Next, pan/zoom the GE window to the initial point you wish to use as Image one. For 
best results, zoom until you are at a viewing height of 2.5Km. You can do that using the 
vertical bar on the right of the GE main window, moving the tiny slider up or down 
slowly by dragging the mouse with the LMB pressed and watching the numbers of "eye 
alt" at the lower right. It is tricky to hit 2.5Km exactly, but be patient. Once you reach the
desired height, do NOT use the mouse wheel in the Main Window again or the height 
will change. Changing the height will change the visual coverage of your tiles and they 
will not register properly on the terrain of your route. To move the map, use the Up, 



Down, Right, and Left keys on the keyboard, or use the LMB carefully to drag the GE 
image around. Always reverify the height is still at 2.5Km.

Also, click the name you have given this route in the My Places area once, turning it blue.
This will ensure that all placemarks in the next steps will be ordered under that folder. If 
they somehow get outside that folder, they can be dragged back into the folder using the 
mouse.

NOTE: At the lower right of the GE main window, there is a small blue circle. When 
moving the displayed image around, this circle will rotate, turning white in the process. 
When it returns to solid blue, it is safe to place the Placemark or use the "N" and "U" 
keys as described below.

Perform these steps repetitively until you have all your images:

1. Hit the "N" and "U" keys once. This will ensure your image is oriented North 
and Vertical (no tilt).

2. Click the Add a Placemark button.

3. A square yellow placemark with a pushpin will appear in the center of the map. 
Leave it where it is placed by default, as moving it will make the geo-coordinates wrong.

4. In the pop-up that appears, give the placemark a name. Make it a short name as 
you will be doing this many times. I suggest "P" and a serial numbering system. Click the
OK button.

5. Move to the GE File menu and Save --> Save Place as...  In the Windows 
dialogue that pops up, save the place in the folder you have prepared. It will be named the
same name as given in the placemark pop-up and under the route name folder in My 
Places.

6. Immediately use the File menu and Save --> Save Image in the same folder 
used in step 5. You will have to type the file name, but not the "jpg" extension as that will
be done automatically when you hit Enter.

7. Use the Down arrow to move the GE image south until the placemark is just 
below the top left of the main window, almost, but not quite, out of sight.

NOTE: If you have moved as far South as you desire, use the UP arrow to move 
back North until you see your top placemark. Place the mouse pointer at the lower right 
of the main window at approximately the same level as the placemark on the left. Press 
and hold the LMB, then drag the image to the left until the map is where you wish to add 
the next Placemark.

Repeat steps 1 through 7, marching south and east, storing .kmz and .jpg files 



until you have completed your desired area. If the placemarks have moved from under 
the route name in My Places, you can drag/drop them back under the route folder name.

If you do not want to do the entire route at one sitting (and that can be horribly 
boring and repetitious) take a break. To reset for the next image in line, double-click the 
last marker you made (under the route name in My Places) and you will be moved to the 
exact spot to continue making placemarks. Remember to move the main image to the 
position for the next placemark in the series first.

When you are finished with your images, you can zoom out until all placemarks 
become visible. This will tell you if you have missed any in the group. If so, double-click 
the placemark in the Route folder in the My Places list to the left (west) of the one you 
missed, move the GE map to the missed area and follow steps 1 through 7.

Finally, ensure you have two files in your disk folder for each image taken in GE. 
There will be a file named "<placename>.jpg" and "<placename>.kmz" for each image 
taken. These files will be used in the next major step in route creation. If you are missing 
these two files, you may have forgotten to Save the placemark .kmz and Save the image 
.jpg file.

You can close GE now if you desire.

Use TransDEM to convert the created images into Georeferenced 
Raster Maps

Everything we do now is done within TransDEM. This part is also tedious, so take your 
time. Note that every menu item mentioned below has a shortcut key sequence and, if 
you are adept at shortcut keys (I am not) by all means use them.

Preliminary:

Open TransDEM and prepare to execute these steps repeatedly to convert your images 
into images that TD can use for your route.

1. Use the Raster Map menu and Open Raster Map. Select <placename>.jpg 
from your disk folder. If this is a subsequent file, you will see a popup asking if it is OK 
to close the current map. Click OK. TD will load the map (accessing the 
<placename>.kmz file automatically) and display the image for that file. A red grid will 
appear on the image, showing Latitude and Longitude.

2. Using the Raster Map menu, move down to Convert to UTM and click it. 
The red grid will shift and change the geographic references from lat/long to UTM.

3. Using the Raster Map menu, move to Save georeferenced Raster Map and 
save the image into the same folder as the jpg files. This will save as 
"<placename>_georef.png" and "<placename>_georef.trf".



Repeat steps 1 through 3 for as many jpg images as you have for your route.

Once you complete converting all the images, open the first image with Raster Map --> 
Open georef Raster Map and select the first "<placename>_georef.trf" file. Continue 
loading the georeferenced .trf files in order. As they are loaded, they will begin to form a 
larger and larger image in the TD window. If you have a lot of files, I suggest you save 
the current larger image in an interim file using a temporary filename. Save georef Raster
Map as "<temporaryname>.lgb" (the .lgb is added automatically). Continue opening 
georef files, saving by overwriting the temporary file occasionally, until all files are 
loaded and you have a complete image of your entire route. If there are "black holes", 
you have skipped one or more files. Go back and gather them, or open them.

With the entire route image file open, make a final save as "<routename>_master" the 
.lgb will be appended when you save it.

At this point, while you have your entire route showing in the main TD window, Use the 
Route --> Simple Route Editor. Note that the small icon on the lower toolbar is now 
depressed. Immediately to the right of that icon is an icon for creating a polyline. Click 
this icon and move the mouse to one end of your route. Each time you click the mouse, a 
segment of route will show as a blue line. Exact alignment is not required, just an 
indication of where the tracks will go on your route. To stop creating the route, double-
click the mouse or hit the Esc key. You may create as many route segments as you desire,
but create the "main line" first and then create any branching lines later.

When finished marking your route, go to the Route --> Save Route and save the route. 
Give it the name of your route. A <routename>.str file will be created when saved. The 
.str will be appended automatically.

Skip the next section if you have already set up the Map Tile Services.

Setup for Map Tile Services

This procedure is detailed in the TransDEM Program PDF file copyright by Roland 
Zieglar. Locate Tutorial 7: Map Tile Services, and follow step A. One-Time setup 
which is used to import and store a ZIP file containing two XML files. Once selected, 
you may skip this step in subsequent route creation.

Creating the route DEM file

  1. Either start or continue with TD. If you do not have the large route image .lgb file in 
the TD window, open it.

  2. Use the TD File/DEM menu and click File name into SRTM .hgt

  3. In the dialog box that opens, write down the DEM info file name(s) that appear inside



the box.

  4. Open your browser and go to this URL: http://dds.cr.usgs.gov/srtm/

       a. Navigate to Version2_1 and then to SRTM3.

       b. Pick your continent or area. A long list of geographical ZIP files will be presented.

       c. Using the web page search function (usually Ctrl-F) and enter the file name you 
wrote down in step 3.

       d. When found, click the link and a download dialog box will show. Save the file into
the same folder you have been saving all information for your route. If more than one 
xxxxxxx.hgt file is given in step 3, locate those files also and save them. They will save 
as .zip files.

       e. Using the TD menu File/ DEM click Open DEM... . Find the folder where you 
just saved the zip file(s) and double-click the file, or one of the files. No need to unzip the
file. A large, color-tinted area will show in the TD main window. Use the TD File/DEM 
and click Save DEM using the default name offered. It will save as a .dem file. If more 
than one file is needed, repeat step e until you have loaded and saved each DEM file.

When the last DEM file is saved, but still present in the TD window, and you have more 
than one DEM file to use, go to File/DEM --> Add DEM... and load DEM files until all 
DEM files are present in the window. For each file you load, a Parameter & Info dialog 
will appear. Accept the suggested values.

       f. Save the joined (or single) DEM file using the TD File/DEM --> Save DEM, 
giving it the name of the route with a new name or a suffix like "_finalDEM". It will be 
saved as a .dem file.

       NOTE: You may use the mouse to draw a box around the portion of the DEM file in 
which your route lies. This box size may be adjusted using the small black dots on the 
perimeter of the box until satisfied. Then, go to the top tool bar, choose the scissor icon 
and click OUTSIDE the bounding box you just created. In the dialog that opens, make 
sure the bottom radio button is active, which will remove all outside the box, turning the 
background black. Click OK.

Ready to create the route and export the UTM tiles

For this portion of the tutorial, ensure that you have loaded both the master .dem file, the 
master .lgb file, and the route .trf files for the chosen route. In order to do this, use the 
File/DEM --> Open DEM and select the route's .dem file and the Raster Map --> Open
georef Raster Map and select the route's master .lgb file. Use the Route --> Open 
Route menu and load the route .trf file.



You will now have the DEM map overlaying the master georeferenced image file and the
route file showing the route as a blue line or lines.

  1. In the TD View menu

    a. Set the coordinate system to UTM

    b. Select Fixed 1000m grid width

  2. In the TD Trainz menu

    a. Select Show baseboard grid

NOTE: If you used the scissors to reduce the size of the DEM originally or not, you may 
use the magnifying tool on the toolbar (the magnifying glass icon) and zoom in on your 
route by using the mouse LMB to zoom in and the mouse RMB to zoom out. It is easier 
to zoom in until the 1000M grid and the baseboard grid shows. Move the map to the 
upper left area of your route.

  3. Activate the Select Tool in the top toolbar (the white arrow icon) and draw a 
boundary box that surrounds all baseboards that are entirely covered by both the DEM 
and the image map. You can adjust the boundaries of the box by moving the line using 
the black points on the perimeter of the box. While the box is being drawn, use the right, 
left, up and down keys to move the map. Drag the corners of the box as desired until the 
whole route is enclosed.

  4. Using the Trainz menu, click "Export and create DEM & ground textures...".

    A dialog box will open containing fields for entry. Utilize the Reset button first for 
default settings.

    Move to the lower portion of the dialog (Map KUID). Your User-ID should already be
entered followed by a unique value for the second field. Ensure both boxes in the Map 
KUID frame are checked.

    You may adjust the amount of baseboards away from the route line by viewing the 
frame labeled "Route filter", put a check in the Apply box, then enter the number of 
baseboards away. If this frame is "grayed out" the route .trf file isn't loaded.

    Move to the Trainz Version frame. In the dropdown I select T:ANE, but you should 
use the version you wish. If you wish to have 5m grids, select the appropriate radio 
button. If you wish to have default fog, check that box.

    Move to the last group, Export Destination. The custom content field should already 
be filled and "grayed out". In the Map Name field, enter the name you chose for your 



route. This is a 15-character field. Use the Region drop-down list to choose a Region. 
Whatever you choose may be altered in Surveyor to a different region. This setting is 
used mainly for which side of the road traffic drives.

    Fill in the target location by clicking the Folder button and navigating to the same 
folder you have saved all the other files for this route.

    Close the dialog by clicking the OK button. This starts the route creation process.

    A new folder within the target folder will be created with the name you entered in the 
Export Destination dialog. It will contain all the files necessary to import the route into 
your chosen Trainz version. For most versions, you simply drag/drop this folder into 
Content Manager for the route to be installed.

Create the route UTM Tiles

As soon as the route is created in the previous section, go to the TD View menu and 
ensure that the coordinate system has been set to UTM grid / WGS84 and the fixed 1000
m grid width  is selected.

Using the mouse with the Select arrowhead active on the upper toolbar, create a box 
around your route, making sure to encompass your entire route and all UTM grids the 
route covers. You may use the black dots around the box to adjust its size.

Move to the Trainz menu and select Export & Create UTM Tiles.

  In the dialog box that appears, ensure that the radio button for "complete 'UTM' objects"
is enabled.

  Ensure that your personal User-ID is entered in the Initial KUID field, followed by a 
unique identifier that will be used as a base for the UTM tile(s).

  Both the "Source Folder for Template 'UTM02' Object" and "Destination Folder 
'Scenery' Objects" should be filled in automatically and "grayed out". If the destination 
folder is not filled in, use the Folder button to the right and locate the disk folder you 
created for your new route and click Select Folder. This is where a new folder entitled 
"Scenery" will be created when you click the OK button.

  The OK button should now be activated. Click it and UTM tile creation will begin. This 
takes time, so be patient and wait until all tile generation is complete. When done, there 
may be a pop-up dialogue that tells you that certain UTM objects could not be found and 
the corresponding tile generation was "skipped". This is usually due to the bounding box 
around your route not being exactly right. However, if you made the bounding box cover 
all the tiles you wanted to generate, the skipped tiles may not impact on your route in any
case. (I normally ignore any such "errors" and continue.)



At this point, you can close TD and open your desired Trainz program, starting up 
Content Manager to be used for route and UTM tile import.

Open Windows Explorer and locate the folder you created for your new route. Within 
that folder is a folder with the name of your new route.

  Drag that folder and drop it into the primary Content Manager frame. The route will be 
imported into Trainz.

Double-click the Scenery folder to open it. Inside you will see one or more folders with a 
name beginning with "UTM". With a large route, this could be a great deal of folders.

  Highlight all of the UTM folders and drag them to the main window of the Content 
Manager. They will be imported into Trainz to be used as 3D tiles on your new route.

Close the Trainz Content Manager and start the Trainz simulator. Navigate to the route 
selection page and select your new route for editing in Surveyor. If all went well, you 
should see your route with Google Earth images overlaying the entire route.

Final Notes:

  If the images do not cover your entire route, you will have to repeat Route Creation and 
UTM Tile Generation once more, but make the bounding box for the route and the 
bounding box for UTM tile generation larger. You might also check to see if the route 
extends everywhere you want it.

  As a preliminary step in route regeneration, I normally delete the just-created route and 
associated UTM tiles, allowing TD to overwrite both route and Scenery folders on your 
hard drive (which TD will do if you do not change the Destination Folders in both the 
route and UTM Tile generation stages. If you want to keep the previous route and UTM 
tiles, simply change the route generation name to a different name. The UTM Tiles 
generation will overwrite (and possibly add more) folders in the Scenery folder for later 
import into Trainz.

Need Help?

  I can be reached on the Trainz Forum as "Hiballer". I will publish this PDF file in a new
thread in the General Trainz panel where you can reach me with your question(s). Please 
let me know of any omissions you spot or clarifications you need.


